Résoudre le « Problem with MergeList » (mise à jour des dépôts)

Rédigé par Maxeric - - 2 commentaires



Lors de la mise à jour de ma Linux Mint 18.1, j'ai eu la mauvaise surprise de me retrouver face à ce message :
E: Problem parsing dependency Depends
E: Erreur apparue lors du traitement de python3-lttng (NewVersion2)
E: Problem with MergeList /var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_xenial-security_main_binary-i386_Packages
E: Les listes de paquets ou le fichier « status » ne peuvent être analysés ou lus.



Après quelques recherches, je suis tombé sur ce billet qui m'a permis de me sortir de cette situation délicate.
Visiblement, "MergeList s’occupe de générer une liste de toutes les sources de dépôts de votre machine en prenant les sources dans /etc/apt/sources.list et celles définies dans le dossier /etc/apt/sources.list.d/, et un conflit est apparu".


Résoudre le problème

Il suffit de supprimer les fichiers générés par MergeList (sans risque) et de les regénérer :

sudo rm /var/lib/apt/lists/* -vf && sudo apt-get update


Merci donc à Jérémy Levallois pour cette solution que je reprends grandement ici (ce site est avant tout un aide-mémoire pour moi...)




Utilisateur de GNU/Linux depuis 2006 (Ubuntu, Xubuntu, Debian, Mint et maintenant Manjaro).
Très sensible aux questions de vie privée, technophile averti, humain avant tout.
Membre de l'April , soutien mensuel de La Quadrature du Net.
Retrouvez-moi sur Twitter et Diaspora


2 commentaires

#1 Gilles a dit :

Très intéressant votre blog, merci beaucoup.

#2 Andre a dit :

Très intéressant votre blog, merci beaucoup.

Écrire un commentaire

Quelle est la troisième lettre du mot naxplx ? :